Failed to resolve: net.nend.android:nend-sdk:x.x.x が出た時のメモ

   

無事Androidでデバッグができるようになりました。

リソースがassetに入っていなくてエラーとか、
SDKへのパスが間違えていたりだとか、
NDKのバージョンが違ったりだとか、
PCとタブレットを繋ぐUSBコードがデータ通信出来ない奴だったりとかしましたが、
無事実機デバッグ完了です。

 

nendを実装したらリリースだ!というところで
結構はまったのでメモメモ。

Failed to resolve: net.nend.android:nend-sdk:x.x.x

https://github.com/fan-ADN/nendSDK-Android/wiki/Android-Studioの場合
http://kawaidesu.hatenablog.com/entry/2015/07/22/111718
このページを参考に実装していきます。

 

「repositoriesにmavenリポジトリの情報を追加します。」
→問題なし

 

「dependenciesに利用するライブラリの情報を追加します。」
→「sync now」をクリックしたところ、下記のエラーが出ました。

Failed to resolve: net.nend.android:nend-sdk:x.x.x

 

「app/libs」に入れているjarファイルと「x.x.x」を合わしてみても、
公式マニュアル通りのバージョンにしてみても、ダメ。

 

調べても、jarファイルのバージョンをそのまま記載したら出来ますみたいな記述しか
なかったため、nend運営会社に質問してみてます・・・。

 

解決したら追記します。

 

2016/4/19 14:45追記
Appのbuild.gradleに「repositories」を自分で追加して、
その中に「url 'http://fan-adn.github.io/nendSDK-Android-lib/library'」を
書くことでGradle buildが通りました。

 

公式マニュアルでは、「repositoriesにmavenリポジトリの情報を追加します。」って書き方してたし、
もう一つ参考にしたサイトではprojectのbuild.gradleに書くと書いてたのに・・・。
これでうまいこと進めばいいんだけど・・・。

 - cocos2dx